summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2017-10-09 14:21:50 +0000
committerintrigeri <intrigeri@boum.org>2017-10-09 14:21:50 +0000
commitd25eeb09729b88da33aeba5a3d4b38e168e6bb13 (patch)
tree65b72621fb32fd891c7bc4fe31892457d868f1a3
parent22d6549dca95adda1bca3e6581bdbb92657bc50e (diff)
Install the "crypto" libblockdev plugin (Closes: #14816).
It's needed by recent udisks to do crypto operations, such as encrypting partitions in GNOME Disks, or creating a Tails persistent volume. udisks2 "Recommends: libblockdev-crypto2" but we're (still?) not installing Recommends by default. So yeah, another case in which we wasted time finding which package was missing…
-rw-r--r--config/chroot_local-packageslists/tails-common.list2
1 files changed, 2 insertions, 0 deletions
diff --git a/config/chroot_local-packageslists/tails-common.list b/config/chroot_local-packageslists/tails-common.list
index ee5a8c8..e156216 100644
--- a/config/chroot_local-packageslists/tails-common.list
+++ b/config/chroot_local-packageslists/tails-common.list
@@ -46,6 +46,8 @@ zenity
libdesktop-notify-perl
# Needed by /lib/live/config/2010-pidgin
bc
+# Needed by tails-persistence-setup on Buster
+libblockdev-crypto2
# Needed by tails-transform-mirror-url
nodejs
# Needed by SSH's ProxyCommand