summaryrefslogtreecommitdiffstats
path: root/features
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2019-03-05 10:23:37 +0000
committerintrigeri <intrigeri@boum.org>2019-03-05 10:23:37 +0000
commit399f80f2179e81409c3646139fab03f0f76a57ed (patch)
tree8ccb0232426ebfab31ee19e55daddf4e3bf98e12 /features
parent740d8b8d542aa59882a2562d3c2dfac92016af9c (diff)
Test suite: fix grammar (refs: #14596)
Diffstat (limited to 'features')
-rw-r--r--features/additional_software_packages.feature6
-rw-r--r--features/step_definitions/apt.rb4
2 files changed, 5 insertions, 5 deletions
diff --git a/features/additional_software_packages.feature b/features/additional_software_packages.feature
index 0775662..28054c0 100644
--- a/features/additional_software_packages.feature
+++ b/features/additional_software_packages.feature
@@ -80,7 +80,7 @@ Feature: Additional software
# install step, as it was not saved in persistence
And I configure APT to prefer an old version of cowsay
And I log in to a new session
- And the package "cowsay" installed version is "3.03+dfsg2-1" after Additional Software has been started
+ And the installed version of package "cowsay" is "3.03+dfsg2-1" after Additional Software has been started
And I revert the APT tweaks that made it prefer an old version of cowsay
# We remove the newest package after it has been downloaded and before
# it is installed, so that the upgrade process fails
@@ -103,12 +103,12 @@ Feature: Additional software
# install step, as it was not saved in persistence
And I configure APT to prefer an old version of cowsay
And I log in to a new session
- And the package "cowsay" installed version is "3.03+dfsg2-1" after Additional Software has been started
+ And the installed version of package "cowsay" is "3.03+dfsg2-1" after Additional Software has been started
And I revert the APT tweaks that made it prefer an old version of cowsay
And the network is plugged
And Tor is ready
Then the Additional Software upgrade service has started
- And the package "cowsay" installed version is newer than "3.03+dfsg2-1"
+ And the installed version of package "cowsay" is newer than "3.03+dfsg2-1"
# Depends on scenario: Recovering in offline mode after Additional Software previously failed to upgrade and then succeed to upgrade when online
Scenario: I am notified when Additional Software fails to install a package
diff --git a/features/step_definitions/apt.rb b/features/step_definitions/apt.rb
index 81c1f61..7f2a827 100644
--- a/features/step_definitions/apt.rb
+++ b/features/step_definitions/apt.rb
@@ -101,14 +101,14 @@ end
When /^I install an old version "([^"]*)" of the cowsay package using apt$/ do |version|
step 'I update APT using apt'
step 'I install "cowsay" using apt'
- step "the package \"cowsay\" installed version is \"#{version}\""
+ step "the installed version of package \"cowsay\" is \"#{version}\""
end
When /^I revert the APT tweaks that made it prefer an old version of cowsay$/ do
$vm.execute('rm -f /etc/apt/sources.list.d/asp-test-upgrade-cowsay.list /etc/apt/preferences.d/asp-test-upgrade-cowsay')
end
-When /^the package "([^"]*)" installed version is( newer than)? "([^"]*)"( after Additional Software has been started)?$/ do |package, newer_than, version, asp|
+When /^the installed version of package "([^"]*)" is( newer than)? "([^"]*)"( after Additional Software has been started)?$/ do |package, newer_than, version, asp|
if asp
step 'the Additional Software installation service has started'
end