summaryrefslogtreecommitdiffstats
path: root/wiki/src/blueprint/freezable_APT_repository.mdwn
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2015-12-14 10:58:22 +0000
committerintrigeri <intrigeri@boum.org>2015-12-14 10:58:22 +0000
commitb02679aa2db5fbd63fe0543a47af1b73c65f12cf (patch)
treea36b7e04ef38c6694c1e30028894a84de71995ae /wiki/src/blueprint/freezable_APT_repository.mdwn
parent11fbc006cbf9b3898b2d6b7913227bd63e0f7d13 (diff)
TODO: take benefit of newly created ticket.
Diffstat (limited to 'wiki/src/blueprint/freezable_APT_repository.mdwn')
-rw-r--r--wiki/src/blueprint/freezable_APT_repository.mdwn28
1 files changed, 13 insertions, 15 deletions
diff --git a/wiki/src/blueprint/freezable_APT_repository.mdwn b/wiki/src/blueprint/freezable_APT_repository.mdwn
index 8238384..56e5eca 100644
--- a/wiki/src/blueprint/freezable_APT_repository.mdwn
+++ b/wiki/src/blueprint/freezable_APT_repository.mdwn
@@ -86,21 +86,19 @@ little value.
- The architecture information is not part of the manifest.
It's fine if `tails-prepare-tagged-apt-snapshot-import` can
do its job without this information. Can it?
- * check source packages handling in
- `tails-prepare-tagged-apt-snapshot-import`, e.g. when the
- binary package's version is different from the corresponding
- source package's one
- * see remaining XXX:s in `tails-prepare-tagged-apt-snapshot-import`
- (`puppet-tails` repo)
- * support for multiple architectures in
- `tails-prepare-tagged-apt-snapshot-import`? needed for multiarch
- that we'll have to use as soon as we want to upgrade Linux
- to 4.x, see [[!tails_gitweb_branch feature/8415-overlayfs]];
- (maybe it's good enough to import all needed packages for
- _all_ architectures our reprepro setup supports? beware of
- differing versions due to binNMUs, though)
- * support for multiple APT repositories (not only suites)
- in `tails-prepare-tagged-apt-snapshot-import`?
+ * `tails-prepare-tagged-apt-snapshot-import`, aka.
+ [[!tails_ticket 10749]] (`puppet-tails` repo):
+ - check source packages handling, e.g. when the
+ binary package's version is different from the corresponding
+ source package's one
+ - see remaining XXX:s in the script
+ - support for multiple architectures? needed for multiarch
+ that we'll have to use as soon as we want to upgrade Linux
+ to 4.x, see [[!tails_gitweb_branch feature/8415-overlayfs]];
+ (maybe it's good enough to import all needed packages for
+ _all_ architectures our reprepro setup supports? beware of
+ differing versions due to binNMUs, though)
+ - support for multiple APT repositories (not only suites)?
e. expand list of source packages with those that the binary
packages were built from [k]
f. have the manifest → partial snapshot process include source