summaryrefslogtreecommitdiffstats
path: root/wiki/src/blueprint/UEFI/syslinux.mdwn
blob: 4ff0aad235a194672dd404e7aaab2508bccaefcd (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
[[!toc levels=1]]

<a id="known_issues">

Known issues
============

See [[support/known issues]].

Miscellaneous test results
==========================

* With Lenovo Yoga 2 Pro, the UEFI nightly release does work, while it didn't
  work previously.
* boots on ThinkPad X220 (syslinux 6.02+dfsg-1 and
  3:6.03~pre1+dfsg-1~bpo60+1) in UEFI mode
* ThinkPad X230 (syslinux 3:6.03~pre1+dfsg-1~bpo60+1):
  - boots fine in UEFI mode, but displays the syslinux menu very much
    translated to the top: one can see the two menu entries, but
    nothing else, so if one must edit the kernel command-line, they
    have to do it blindly
  - boots fine in Legacy BIOS mode, so at least we have no hardware
    support regression here
* boots on ThinkPenguin Royal (syslinux 6.02+dfsg-1 and
  6.03~pre1+dfsg-1)
* boots on MacBook Pro 13-inch Mid 2012 9,2 (EFI 2.9), and MacBook Pro
  13-inch Late 2011 8,1 (EFI 2.7), both with and without rEFInd *if*
  `menu background splash.png` is removed from `stdmenu.cfg`; adding
  `menu resolution 640 480` before `menu background` makes the menu
  display "correctly" (only taking 1/4 of the screen, but oh well),
  *but* the system does not boot; without rEFInd, one has to press Alt
  before powering the laptop up, and keep it pressed until a menu
  appears, and then choose the entry that's called *Boot EFI* (as
  every other entry) and looks like a USB stick.
* on MacBook Pro 13-inch Mid 2012 with rEFInd, one has to choose
  *Fallback boot loader from Tails* in rEFInd to boot, as the *Boot
  Linux from Tails* entry does nothing at all (syslinux 6.02+dfsg-1
  and 6.03~pre1+dfsg-1)
* The ThinkPenguin Royal does not detect the bootloader if installed
  as `EFI/Tails/syslinux.efi`; hence the use of the fallback bootloader
  path (`BOOT/bootx64.efi`), which should work on more hardware.
* tails-i386-feature_uefi-0.23-20131222T0855Z-8acf864.iso
  boots fine on a Apple MacBook Air 13" mid 2011 (MacBookAir4,2)
  once installed with Tails Installer
* MacBook Pro 15-inch Mid 2010 (6,2) boots fine with rEFInd and
  tails-i386-feature_uefi-0.23-20131222T0855Z-8acf864.iso, *if* `menu
  background splash.png` is removed from `stdmenu.cfg`; if one
  adds `menu resolution 640 480` before `menu background`, the system
  does not boot.
* Lenovo ThinkPad X130e:
  tails-i386-feature_uefi-0.23-20140104T0920Z-3305611.iso boots fine.
* Lenovo E325: tails-i386-feature_uefi-0.23-20140104T0920Z-3305611.iso
  boots fine.
* MacBook Air Original (1,1): one has to press Esc twice in rEFInd to
  have it see the USB stick; then, rEFInd apparently loads syslinux,
  that fails to display its menu, even after commenting out most
  menu-related setting that has to do with color or positioning.
  Finally, Tails does not boot.
* ASUSTeK COMPUTER INC. X55VD: boots fine with `menu background
  splash.png` removed (both with CSM enabled and disabled); only boots
  in CSM mode with `menu background splash.png` kept in place
* Boots fine on ThinkPad W520 (tails-i386-feature_uefi-1.0-20140324T1026Z-dd350d4.iso).
* Boots fine on Lenovo ThinkPad E320 (tails-i386-feature_uefi-1.1-20140407T1357Z-02a2adf)
* Boots fine on Macbook Pro 11,3 (15 Inch Retina-Late 2013)
* Boots fine on Late 2013 Macbook Pro 13" Retina
* Boots fine on Macbook Air 3,1 in UEFI mode
* Boots fine on HP/Compaq 6330s in UEFI mode
* ThinkCentre M82 boots fine with:
  - an alpha generation (isohybrid + dd) USB stick
  - a beta generation (prepared with Tails Installer) USB stick in
    both UEFI and "legacy" BIOS mode
* Boots fine on ASUS 701 (eeepc).
* Boots fine on Acer Aspire E1-531 (V2.09, EFI v2.31) in UEFI mode.
* Boots fine on MacBookPro8,1 (Early 2011, Model A1278).
* Boots fine on Gateway NE56R w/ Bios V2.13 in UEFI mode, with Secure
  Boot disabled. Doesn't boot (as expected) with Secure Boot enabled.
* Boots fine on Hewlett-Packard Presario CQ57
* Boots fine on Apple MacBook Air 3,2 A1369 EMC 2392, with rEFInd
  0.7.8 installed, when installed with isohybrid + dd.
* Boots fine on ASUS ux31a
  - in CSM mode, when installed with isohybrid + dd
  - in UEFI mode, when installed with Tails Installer
* Boots fine on Lenovo Thinkpad T400.
* Boots fine on Mac Mini 2.3 Ghz Intel Core i7 from DVD, and from USB
  stick created with Tails Installer.
* Boots fine on MacBookAir5,1 from DVD, and from USB stick created
  with Tails Installer on the same machine.
* Boots fine from DVD on VirtualBox 4.3.10-dfsg-1~bpo70+1 (as of commit e0a3c64
  in `feature/uefi`).
* Boots fine on Lenovo G700.
* Boots fine from DVD on Lenovo B570.
* Boots fine from DVD on Lenovo Z61t.
* Boots fine from DVD on HP Pavilion dm4-1150ca.
* Boots fine on Asus Z87 Pro motherboard (Tails 1.1~beta1) off a USB
  stick installed with Tails Installer.

# Tests with syslinux 3:6.03~pre18+dfsg-1~bpo70+1

* MacBookPro 13-inch Late 2011 8,1. All what follows is using a USB
  device installed with Tails Installer, using an experimental ISO
  (20140731) with syslinux 3:6.03~pre18+dfsg-1~bpo70+1. The same
  computer boots Tails 1.1 just fine.
  - boots just fine with the default configuration
  - uncommenting `menu background splash.png` in
    `EFI/BOOT/stdmenu.cfg` => stuck at the Mac boot menu
  - same as above, and add `MENU RESOLUTION 1024 768` to
    `EFI/BOOT/tails.cfg` => displayed *once* the syslinux boot menu
    with the expected background image, can edit the kernel cmdline,
    but does not boot (display stuck at the syslinux menu); and then
    I can't reproduce it, and it's stuck at the Mac boot menu, like
    when `MENU RESOLUTION 1024 768` wasn't here.
  - same as above, but with `MENU RESOLUTION 640 480`
    => stuck at the Mac boot menu
* TOSHIBA PORTEGE Z830: boots fine with `isohybrid --entry 4 --type
  0x1c` and a <1GB ISO.
* TOSHIBA PORTEGE Z930: boots fine from a stick installed with Tails
  Installer (from DVD), while it did not boot with Tails 1.1.