summaryrefslogtreecommitdiffstats
path: root/wiki/src/blueprint/easier_YouTube.mdwn
blob: cf6ae7018535f445cefc8b5577a3d6f1407af533 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
[[!toc levels=2]]

Next steps
==========

0. integrate the test reports below and the next steps they suggest as
   part of this roadmap
0. wait a bit for [[todo/smtube]] to mature; if
   it's acceptable and merged, then perhaps we will consider the
   *easier YouTube* task as completed.
0. [[todo/benchmark_YouTube_HTML5_addons]]
0. make audio and video codecs autoplay (so that the Tails web browser
   works in a less surprising way, especially for new users; also, the
   idea is that when one goes to a page with audio or video objects,
   they want to read them more often than not)

Alternatives
============

* [[todo/Flash_support]]
* [YouTube Video Download for
  Greasemonkey](https://userscripts.org/scripts/show/62634)

Background
==========

* [[!tor_bug 3347]]

Test reports
============

Out-of-the box YouTube support in Tails 0.18
--------------------------------------------

With Tails 0.18, I visited one of the featured videos on youtube which
is <https://www.youtube.com/watch?v=aK_eKGK4JrM>.

At first it gave me the usual msg flash player, then I added
`&html5=1` on the URL and refreshed the page. It worked as it should
be no issues. After that, most of the videos played out of the box
without the `&html5=1` that where on the right side as
featured/similar.

> I can reproduce this with 0.19. However, one still has to
> click-to-play their way through the "Additional plugins [...]"
> message. --intrigeri

From one of them I got the msg "The browser does not currently
recognize any of the video formats available."

Later I entered <https://www.youtube.com/html5> where I verified that
my browser does not support h.264, also I had the msg "You are not
currently in the HTML5 trial." Hope that helps.