summaryrefslogtreecommitdiffstats
path: root/wiki/src/news/version_1.2.2.mdwn
blob: 1ae09e52e18b96834a3d357aef08fbc59a6817f5 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
[[!meta date="Fri, 16 Dec 2014 12:34:56 +0000"]]
[[!meta title="Tails 1.2.2 is out"]]
[[!tag announce]]

Tails, The Amnesic Incognito Live System, version 1.2.2, is out.

This release is an emergency release that changes the root certificate
which is used to verify automatic upgrades.

On January 3rd, the SSL certificate of our website hosting provider,
boum.org, will expire. The new certificate will be issued by a different
certificate authority. This certificate authority is verified by the
automatic upgrade mechanism of Tails.

As a consequence, versions
previous to 1.2.2 won't be able to do the next automatic upgrade to
version 1.2.3 and will receive an error message from *Tails Upgrader*
when starting Tails after January 3rd.

On top of that, a [[!tails_ticket 8449 desc="bug in *Tails Upgrader*"]]
prevents us from providing an automatic upgrade from version 1.2.1 to
1.2.2.

So all users should either:

  - Do a [[manual
upgrade|doc/first_steps/upgrade#manual]] to version 1.2.2 before January
3rd. (recommended)
  - Remember to do a manual upgrade to version 1.2.3 on January 14th.

[[!toc levels=1]]

# Changes

  * Minor improvements

    - Change the SSL certificate authority expected by Tails Upgrader
      when checking for new Tails versions on https://tails.boum.org/.

See the [online
Changelog](https://git-tails.immerda.ch/tails/plain/debian/changelog)
for technical details.

# Known issues

The same issues as in 1.2.1 apply to this release:

* It is [[hard to exchange files with the I2P Browser|support/known_issues#i2p_browser]].

* [[Longstanding|support/known_issues]] known issues.

# For users of persistent GnuPG keyrings and configuration

If you have enabled the <span class="guilabel">GnuPG keyrings and
configuration</span> persistence feature and have *upgraded* a Tails
USB stick or SD card installation to Tails 1.2.1 or 1.2.2, then please follow
these steps to benefit from the updated GnuPG configuration:

1. Boot Tails with
   [[an administration password|doc/first_steps/startup_options/administration_password]] set.

1. Run this command in a <span class="application">Root
   Terminal</span>:

    cp /etc/skel/.gnupg/gpg.conf /home/amnesia/.gnupg/gpg.conf

# I want to try it or to upgrade!

Go to the [[install]] page.

As no software is ever perfect, we maintain a list of [[problems
that affects the last release of Tails|support/known_issues]].

# What's coming up?

The next Tails release is [[scheduled|contribute/calendar]] for
January 14.

Have a look at our [[!tails_roadmap]] to see where we are heading to.

Do you want to help? There are many ways [[**you** can
contribute to Tails|contribute]]. If you want to help, come talk
to us!